RH850:How to use the hot plug function of e² studio? Renesas e² studio Version: 2022-10 (22.10.0)

I encountered a problem when using the hot plug function, as shown in the picture below. Does anyone know the reason? How to solve it? Thank you so much!

I set the hot plug to YES

Then I connected the debugger to the target board and hit OK.The problem in the image below occurs.

Does anyone know why that is? Is there a problem with my debug configuration or something? Thank you very much.

  • If using the E1/E20, are you using the hot-plug adapter?  if using the E2, do you have the ground connected first, before physically plugging in the debugger?  

    I have only ever done this using CS+, and the process was quite simple and straightforward.  I might recommend you give CS+ a try and if that works, then you can go back to e2studio if so desired.

    The only possible red-flag I could see in your configuration is the setting to "Set OPJTAG in LPD connection before connecting" is YES, this may cause the debugger to first try to connect in serial programming mode to check and set the option bytes to enable debugging.

  • Thank you for your reply.

    I tried grounding the E2 debugger before physically plugging it in and setting to "Set OPJTAG in LPD connection before connecting" is NO .But the problem still exists.I would like to know what is the configuration of CS+ in this process. Can you show me what the configuration is like in CS+?

    Thank you so much.

  • Unfortunately I do not have RH850 on which to test, but I believe this configuration that i created now would work on the F1K device:

    So long as the debugger was doing minimal action or intervention to the device, and the clock setting was correct it should work.

  • Tried the same Settings as you, except without the "Mount main clock on target borad" setting on the first line.

    The problem is still unresolved...

    Have you ever encountered this mistake? What could be the reason?Dizzy face

  • I might suggest that you post to the e2studio forum where the tool experts would be more likely to help out.

Reply Children
No Data