apt install for v4h and s4 board


I have a question regarding the package management in yocto image, when I bitbake the image (bitbake rcar-image-adas) and I am inside the linux environment, how can I install any packages?

How can I get apt install work inside the linux environment. I enabled IMAGE_INSTALL_append = "apt" and EXTRA_IMAGE_FEATURES = "package-management" in my local.conf file.

But still apt install not working for me. Any suggestions?

Thank you,

Parents Reply Children
  • Hi ,

    Thank you for the clarification. I tried:

    EXTRA_IMAGE_FEATURES +="package-management"

    IMAGE_INSTALL_append = " opkg "

    in the local.conf

    but when I log in inside the v4h board:

    opkg update not showing any list

    I tried opkg update

    and opkg list and not returning anything just no error message.

    My question is where it gets the list from? For example apt will get it from some repository to update/upgrade or install but this opkg package manager where does it get the list from?

    when I run opkg install nano

    I will get the following error:

    My second question is the apt folder is inside the poky folder. It doesn't have any usage?

    Thank you for your time and support.