Not able to record audio using ALSA on RZ/A1H board


I am working on Renesas RZ/A1H platform with Linux Operating system.

I am trying to record audio using alsa with below command. 

$ arecord --format=S16_LE --rate=16000 --channels=1 test.raw -vv

The recorded audio has noise only. The audio codec is MAX9856 and I am using Audio-In port as "Audio Line-In". I have tried with all the different combination of sampling rate and channels but not able to record the voice. The configuration of Mixer is a default, I did not change any configurations. With default configurations of mixer, it is using LINEIN1 and LINEIN2 as input. I have tried with all different configuration but not able to record voice. The recorded audio has been tested with "aplay" command as well as with audio player in other systems after converting it into the required format.

When I use headphone as a recording device and insert headphone in Audio-In port then I was able to record voice from Audio-In port. (When I use headphone for recording I need to use earplugs to speak into it not microphone). Because of this scenario, I changed configurations of "Audio-In" port and make it as "Audio-Mic In" and change the required configurations with the use of "amixer" command but still not able to record the audio from the device. Can anyone please help me to record audio from "Audio-In" port of the device?

Please let me know if I need to put more information here for this issue. Looking forward to your support.

Thank you.