Web Server Example Code - PK - S5D9


Hope everyone is having a great easter.

Im currently struggling to get the code for a NetX/NetX Duo example projects working on the PK-S5D9. Below is a list of things ive tried. The code can be downloaded from here: https://www.renesas.com/us/en/products/synergy/hardware/kits/pk-s5d9.html#downloads - page two of the downloads list.

  1. Imported both projects into e2 and configured the IP to be a static IP (Checked the router and its not one that is currently used and is within the IP range of my router) and its not connecting. Now since everyone loves LEDs. Ethernet has two and only one of them is flashing (the orange one). – Just a note when I say ive imported them into the IDE. Its been independent of one another and when trying to run either of them the second one if present has been closed.
  2. Ive connected the device to the router and then checked the connections to the LAN network (Currently Lan3)  and as you can see its registering speed but not the device. (also tried four).
  3. Ive also tried connecting directly to the pc again with the same IP as before and tried pinging it from the command line and tried connecting directly in chrome and neither have worked sadly.
  4. Ive tried replacing the static IP allocation with a DCHP client connection within the code and that hasn’t worked either sadly.
  5. Default gateway set to the IP of the router (as the PC).
  6. Stepped through the code to see if its erroring at all and all the threads are executing but seem to be waiting for something to happen (tx flags),
  7. The guide says a usb device is needed ive checked that and nothing is wrote on it so im not sure what that is required for.

 The only thing i havent checked as im struggling to get hold of the schematics (apologies if theyre infront of me and im looking in the wrong place) is the pin allocation for the ethernet channel. Ive seen previous forum posts saying that there is only a single channel on here and C0 is set to IOPORT_PORT_08_PIN_06 currently. (C1 is also allocated to the same pin).

Ive checked through the code and nothing seems to be failing to Init as well.

Im now at a bit of a loss as to what to try next or what the issue is. If you have any advice that would be greatly appreciated.