This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

AWS Cloud connexion issue with NXD_MQTT_COMMUNICATION_FAILURE error; (0x1007)


I have a connection problem on AWS Cloud.

I did create my Device on the account, as well as its shadow and embedded the 3 certificates: AmazonRootCA1.pem, .cert.pem, and .private.key

each of these certificates is well recognized by the nx_secure_x509_certificate_initialize, nx_secure_tls_trusted_certificate_add and nx_secure_tls_local_certificate_add functions.

Error 0x1007 is returned by the nxd_mqtt_client_secure_connect function after a correct nxd_mqtt_client_secure_connect and a first _nx_secure_tls_handshake_process as well. However, nx_secure_tls_session_receive ends up returning the error 0x56, (NX_NOT_CONNECTED).

Note that my code was adapted for AWS because it originally worked for Cloud Azur. I could not use the AWS AE Cloud2 example code because it does not compile despite the SSP v1.7.8 version for which this code is intended.

I hope someone here can help me?

Best Regards,

Eric F.

[locked by: Sai (SWF) at 14:53 (GMT 0) on 23 Jan 2023]
  • Hi Eric,

    How are things going? Were you able to figure out this one? We've been looking for any information or documentation about this issue but unfortunately, we weren't able to find something that could help.  We're now escalating it to second level support and will get back to you ASAP.  Thank you for your patience!

    If this response, or one provided by another user, answers your question, please verify the answer. Thank you!
    Renesas Engineering Community Moderator

  • Hi Eric, The connection issue could be because of mismatch in the user credentials from cloud account. So even though "nx_secure_x509_certificate_initialize" is ok, the certificate verification is not completed until connection is successful. Have you tried deleting the device on the account and creating new one?

  • Hi Neelima,

    thanks for your message.

    I solved my problem, the problem was that I had not attached the policy file to my certificates. This process did not exist in Azure.

    Thank you.

    Eric F