Display Not Working

I'm using a Custom board with R7FS7G27H3A01CFC , SSP 1.6.0 , toolchain 4.9.3.20150529 , GUIX 5.6.1.0 , 4.3 TFT Display

I'm trying to execute my code on this board which have Gui screen , the code is running properly like ADC ,DAC etc. but the Gui is not displaying on screen , the Backlight Turn on but the screen doesn't. Can any help me with this ? 

Here is the initialization code:- 

void HMI_Thread_entry(void)
{
/// Initialize GUIX System ///

sf_message_header_t * p_message = NULL;
UINT status = TX_SUCCESS;

tx_thread_sleep(10);
tx_thread_sleep(10);

// start the sub-clock
g_cgc.p_api->clockStart(CGC_CLOCK_SUBCLOCK, NULL);
// wait 1 seconds for the resonator to stabilize
R_BSP_SoftwareDelay(2, BSP_DELAY_UNITS_SECONDS);

status = g_rtc.p_api->open(g_rtc.p_ctrl, g_rtc.p_cfg);


status = g_rtc.p_api->periodicIrqRateSet(g_rtc.p_ctrl, RTC_PERIODIC_IRQ_SELECT_1_SECOND);

status = g_rtc.p_api->calendarCounterStart(g_rtc.p_ctrl);

status = g_rtc.p_api->irqEnable(g_rtc.p_ctrl, RTC_EVENT_PERIODIC_IRQ);

/// Initialize time-keeping hardware. ///
system_time_init();

/// Update time for the splash screen. ///
g_rtc.p_api->calendarTimeGet(g_rtc.p_ctrl, &g_system_state.time);


tx_thread_sleep(10);

/// Initializes GUIX. ///
status = gx_system_initialize();
if(TX_SUCCESS != status)
{
while(1)
{;}
}


/// Initializes GUIX drivers. ///
err = g_sf_el_gx.p_api->open (g_sf_el_gx.p_ctrl, g_sf_el_gx.p_cfg);
if( SSP_SUCCESS != err )
{
while(1)
{;}
}

/// Set up GUIX Renderer ///
gx_studio_display_configure (MAIN_DISPLAY,
g_sf_el_gx.p_api->setup,
LANGUAGE_ENGLISH,
MAIN_DISPLAY_THEME_1,
&p_window_root);

///Initialize drawing canvas created by GLCDC///
err = g_sf_el_gx.p_api->canvasInit(g_sf_el_gx.p_ctrl, p_window_root);
if(SSP_SUCCESS != err)
{
while(1)
{;}
}

/// Shows the root window to make it and patients screen visible. ///
status = gx_widget_show(p_window_root);
if( TX_SUCCESS != status )
{
while (1);
}

/// Lets GUIX run. ///
status = gx_system_start();
if(TX_SUCCESS != status)
{
while(1);
}

/// Enable the display ///
status = g_ioport.p_api->pinWrite(IOPORT_PORT_07_PIN_00, IOPORT_LEVEL_HIGH);
if(TX_SUCCESS != status)
{
while(1);
}

;
GX_CONST GX_STUDIO_WIDGET ** pp_studio_widget = &HMI_APP_widget_table[0];
GX_WIDGET * p_first_screen = NULL;

while(GX_NULL != *pp_studio_widget)
{
if (0 == strcmp("Boot_Screen", (char*)(*pp_studio_widget)->widget_name))
{
gx_studio_named_widget_create((*pp_studio_widget)->widget_name, (GX_WIDGET *)p_window_root, GX_NULL);
} else {
gx_studio_named_widget_create((*pp_studio_widget)->widget_name, GX_NULL, GX_NULL);
}
pp_studio_widget++;
}

gx_widget_attach(p_window_root, p_first_screen);

/// Enable display backlight ///
status = g_ioport.p_api->pinWrite(IOPORT_PORT_07_PIN_03, IOPORT_LEVEL_HIGH);
if(TX_SUCCESS != status)
{
while(1);
}

while(1)

{//Code//}

Thanks in advance.