Headless Build Synergy Issue

Note: I wanted to ask this in the e2 Studio forum, but don't have permissions or something to ask questions there. And the error seems like it may be Synergy related, so maybe this is the right spot anyway.

I recently upgraded our application from SSP 2.2.0 to SSP 2.5.0 and e2 Studio from 2021-10 to 2023-07. Prior to the upgrade, our CI pipeline was successfully able to build using the eclipse headless build module. Post upgrade, our build from within e2 Studio is functioning fine. Our headless build script command is not working:

C:\Renesas\Synergy\e2studio_v2023-07_ssp_v2.5.0\eclipse\e2studioc.exe -nosplash -consolelog -application org.eclipse.cdt.managedbuilder.core.headlessbuild -data %SCRIPTDIR%\DomainDebug -import %BUILDDIR%\Domain -build Domain/Debug >> %SCRIPTDIR%\DebugOut.txt

This is what the log of e2 Studio looks like:

Opening 'Domain'.
!SESSION 2024-02-08 16:20:32.242 -----------------------------------------------
java.vendor=Eclipse Adoptium
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -application org.eclipse.cdt.managedbuilder.core.headlessbuild -import D:\dpxfan\firmware\denali\Domain -build Domain/Debug
Command-line arguments: -os win32 -ws win32 -arch x86_64 -consolelog -application org.eclipse.cdt.managedbuilder.core.headlessbuild -data D:\dpxfan\firmware\denali\BuildScripts\Output\DomainDebug -import D:\dpxfan\firmware\denali\Domain -build Domain/Debug

!ENTRY com.renesas.common.supportfiles 4 0 2024-02-08 16:20:37.502
!MESSAGE Error getting support target location
org.eclipse.core.runtime.CoreException: Path missing for com.renesas.ide.exttools.synergy.build.buildSupportFileTarget
at com.renesas.common.supportfiles.internal.service.SupportPluginExtension.getResolvedPath(SupportPluginExtension.java:85)
at com.renesas.common.supportfiles.internal.service.SupportFilesService.getTargetLocation(SupportFilesService.java:79)
at com.renesas.common.supportfiles.vars.TargetLocationVariableResolver.resolveValue(TargetLocationVariableResolver.java:32)
at org.eclipse.core.internal.variables.DynamicVariable.getValue(DynamicVariable.java:56)

  • Hello,

    Thank you for reaching out. In order for us to investigate further, can you please provide your target synergy device? Kindly also confirm if your e2 is also in Windows? Thank you!


    If this response, or one provided by another user, answers your question, please verify the answer. Thank you!
    Renesas Engineering Community Moderators

  • Hi Jef,

    Continuing to investigate on our side. If you're following the bottom, I think I've figured out where the discrepancy is. I did a test using the S7G2_DK pack file. When I simply copy the PACK file to another location, and import it, I get this in the e2 Studio console:

    When I instead change the .PACK to a .zip, unzip, and then recompress it to a .zip and rename to a .PACK again, this is what I get:

    Installing Synergy support files: Renesas.Synergy_board_s7g2_dk.2.5.0.pack... Installation complete.

    When I instead change the .PACK to a .zip, unzip, and then recompress it to a .zip and rename to a .PACK again, this is what I get:

    Installing Synergy support files: Renesas.Synergy_board_s7g2_dk.2.5.0.pack... No support files present.

    So it seems like the old knowledge base article we had based creating our pack file off of is no longer valid. That article - I can no longer find it - mentioned that the pack files are simply zip files, and to create a custom BSP, to simply unzip a basis package, alter as needed, then rezip and rename. It does not seem like the zip that e2 Studio uses to interpret the pack file is the same zip Windows uses. Any advice on how to zip up the package into an e2 Studio compatible format?

  • A pack file has to be compressed with DEFLATE compression method :- 


  • This is what I was using. I did fix an issue on my end - I was including an upper folder in the zip that I should not have.

    However, the new BSP was still not showing in the drop down. It didn't show in the drop down until I manually copied the .module_descriptions folder's files into the correct location. After that, evertyhing worked (see my latest response to Jef).

  • Without seeing the pack file, I can't comment any further.

Reply Children
No Data