Flashloader_pack1.X.0.exe

I right now am following the guide on the flashloader example at

https://synergygallery.renesas.com/media/products/74/193/en-US/r11an0073eu0100-synergy-ssp-flashloader.pdf

I am trying to get this working but require  Flashloader_pack1.2.0b1.exe. I cannot find this download on the website or is there a place where I can download  Flashloader_pack1.3.0.exe since I am using SSP 1.3.0.

I looked in the e2_studio install directory and still cannot find anything. Please let me know where I can find the flashloader pack or where to download it.

I am using the SK-S7G2 starter kit.

Parents Reply Children
  • Hi

    My project is made with ssp 1.3.3 and it includes the sf_downloader modules, of the ssp version 1.3.0. I have updated an SSP 1.4 and everything related to ssp 1.3 has disappeared. Is there any update for this new version of ssp?

    thanks
  • Hi feraro,

    Currently there is no official updated version of the Flashloader framework for SSP 1.4.0. You may try the following ported version, but please keep in mind this is not official version (rename to Renesas.Synergy_flashloader.1.4.0.pack and put to 'packs' directory, most likely C:\Renesas\Synergy\e2studio_v6.2.0_ssp_v1.4.0\internal\projectgen\arm\packs):

    Renesas.Synergy_flashloader.1.4.0.pack.zip

    Regards,
    adboc

  • HI all,

    I have the same problem, i have a project which uses bootloader Framework with ssp 1.3.3. I migrated to the e2 studio 6.2.0 version and use now ssp 1.4.0. When i opened the project on the new environment, bootloader component has been removed.

    How can I use the Renesas.Synergy_flashloader.1.4.0.pack.zip? What is the procedure to import it?

    thanks
  • HI Bj,

    You should unzip the file and place the unzipped .pack file in internal/projectgen/arm/packs folder in e2 Studio directory, for example: C:\Renesas\Synergy\e2studio_v6.2.0_ssp_v1.4.0\internal\projectgen\arm\packs

    Regards,
    adboc
  • Hi adboc,

    I unzipped the Renesas.Synergy_flashloader.1.4.0.pack and put it in internal/projectgen/arm/packs. What should I do to use it in my e2 studio project? I mean to refer to sf_bootloader.h for example

    Thanks
  • Hi Bj,

    In the configurator, please open Threads tab > New Stack > Renesas > Flashloader - there will be all flashloader frameworks available.

    Regards,
    adboc
  • When I unzip the folder Renesas.Synergy_flashloader.1.4.0.pack.zip and put it in the internal\projectgen\arm\packs, it appears as a folder and nothing happens in e2 Studio.

    Otherwise, if I just rename Renesas.Synergy_flashloader.1.4.0.pack.zip to Renesas.Synergy_flashloader.1.4.0.pack and put it in internal\projectgen\arm\packs, it seems to be regonized as a pack file since I have a message in e2 sutdio which makes me notice that "Changes to the CMSIS Pack Folder have been detected"

    However i can't see the module in Threads tab > New Stack > Renesas > Flashloader. Is there sonmething I missed?

    Thanks
  • I made that I described above and I restarted e2 studio, I can see now Flashloader in Threads tab > New Stack > Renesas .
    However there are only three possibilities and not the one I used in Renesas.Synergy_flashloader.1.3.0.pack . Bootloader Framework on sf_bootloader_mcu is missing in Renesas.Synergy_flashloader.1.4.0.pack
    Does anyone have a suggestion?
  • Hi Bj,

    Sorry, you're right, it's needed to rename *.pack.zip to *.pack and place it in packs/.

    I've just created a new project and see the Bootloader Framework on sf_bootloader_mcu available. Have you selected SSP 1.4.0 in BSP tab?

    Regards,
    adboc

  • Hi adboc,

    Thanks for your help, I also tried with a new project and I could see all modules. However, I couldn't see them in my existing project so I deleted it from my workspace and imported it again.

    When I opened my project and built with SSP 1.4.0, it didn't remove bootloader component (certainly because the pack is recognized) and the build is ok.

    However I still can't see all modules in Flashloader but my project works, it's not a problem for now but I can't add some modules if needed.

    Thanks,

    Bj