Why show "Invalid ROM Table", when debug with Keil + ULINK2 on EK-RA6M5 board

Dear forum:

I want to confirm, can we use Keil + ULINK2 for futrue development.

So I tried the following:

I use Keil as the IDE, ULINK2 as the debugger.

Keil settings is shown as below:

  

but ,when download, It shows the following error:

If I change to J-LINK, it works correctly.

Can I use ULINK2 ?

Many Thanks.

  • Hi Half sleeve prince,

    Thanks for reaching out to our Engineering Community.

    The On-Board Debug (via micro USB connection) is supported only with J-Link firmware. In order to use ULINK2, I think the best solution is to connect with an external Keil ULINK2 debug adapter. You can see this tutorial for related information. 

    Also, could you check your jumper configurations ? The correct configurations for EK-RA6M5 are like below:

    Debug on-board is implemented with just a micro-USB connection while debug-in is implemented with an external debugger.

    Let us know if you figured out the issue.

    Regards,

    AZ_Renesas

  • Dear

    I set the jumper as following:

    the board photo:

    Then, I do the following confirm:

    1. On board Debug, Can't find device, I think this is OK.

    2. External J-link Debug, It works well.

    the photo:

    3. External ULINK2 Debug, It can find the device, but when download, it shows "Invalid Rom tables",  It can't work.

    the photo:

    Can you help to confirm,

    Many Thanks.

  • Hi Half sleeve prince,

    Could you take a look on the settings on this guide ?

    Also, could you share the configurations on the "Flash Download" tab ? Maybe if you selected "Erase Full Chip" would help. Please make sure you add the correct items in "Programming Algorithm" and confirm ULINK2 adapter is recognized by Windows like here .

    Let us know the results.

    Regards,

    AZ_Renesas

  • I revise the settings as below, but it doesn't work too.

      

    and my pc can recognize the ULINK2 correctly.

    Can you  help to confirm?

    Many thanks.

  • Hi Half sleeve prince,

    We are currently investigating your issue within our team and we will get back to you.

    Could you try changing size in RAM Algorithm to 0x00080000 (same as SRAM size of RA6M5)  just in case ?

    Regards,

    AZ

  • Dear AZ_Renesas

    I change the setting as below:

    It shows the same error "Invalid ROM table".

    Many Thanks

  • Hi Half sleeve prince,

    After some consideration we think you should configure Debug & Reset Options as followed:

    Connect: Normal

    Reset: Autodetect

    Please keep in mind that using a ULINK debug probe rather than a J-Link (such as the J-Link OB on the EK-RA6M5) with MDK will mean that it will be necessary to update the MCU’s TrustZone Partition Boundaries (and longer term the Device LifeCycle Management state) using a tool such as Renesas Flash Programming through a serial/USB connection to the MCU, as ULINK does not contain the appropriate support to interface to the MCU’s boot mode.

    Let us know if you solved the issue.

    Regards,

    AZ