Ethernet Connection Not Working on Newer Routers

First time posting here!

This is a strange problem that I am trying to isolate. I would appreciate any ideas about the issue.

I am having issues with making a wired connection on newer routers. My device connects properly to my older router and also is able to connect if I create a bridge to the Ethernet port on my Mac-book.

The problem seems to arise on newer routers. I was first unable to connect to my ISP’s router, so I bought a newer router and have the same problem. Here’s some of the details.

First of all the lights on my Ethernet port do not even flicker with the newer routers. If I connect the Ethernet to the Ethernet port on my Mac-book, it instantly flickers and works.

vEtherISRCallback will not be called on these newer devices, but will immediately be triggered when plugged into the older routers.

My device sends out a DHCP discover, but I am thinking the problem is at the Ethernet level due to this interrupt not being triggered? Could there be a newer protocol on these newer devices that I am not aware of?

Any thoughts would be appreciated, even brainstorming.

Parents
  • I think you are correct that it's not a DHCP. Is your PHY on your board setup to auto negotiate the speed between 10/100/1000BaseT and full/half-duplex? Is the router (actually you sound like you're using a Layer 3 switch or similar) set up to handle negotiating a normal or uplink port automatically or are you using a cross-over cable accidentally?

    Also, by "my device", is this some sort of Renesas eval board? What kind and what are you running?

    -Larry

  • Thanks Larry for the response!

    From what I can see I believe that we can do 10/100 for negotiation, but I don't see 1000. I believe Half/Full duplex is supported for both 10/100.

    For routers that did not work I used my ISP's router. This is a Telus Wifi Hub, no real model name unfortunately. Secondly I used an Eero 6+ router.

    It does not look like I am using a cross over cable, and I have tested with multiple different cables.

    I am using a custom board, but the Rareness controller is the RA6M3 A6M3AF3CFC.

    Also please let me know if you need any further explanation from me. I am semi new to this, so will let you know if I am ever not following along.

  • Can you post the configuation of your ethernet and PHY from the graphic setup in the IDE.

    Thanks

    Lc

  • Hi Larry,

    Are these the photos that you were requesting? See attached images below.

Reply Children