Using FSP 4.5.0 on Windows I can not build a C++ application

Using the wizard or an FSP example (cpp_ek_ra6m5_ep) give:

c:\users\davidd\appdata\local\programs\renesas\ra\e2studio_v2023-04_fsp_v4.5.0\toolchains\gcc_arm\gcc-arm-none-eabi-10.3-2021.10\arm-none-eabi\include\c++\10.3.1\cstdlib:41:10: fatal error: bits/c++config.h: No such file or directory

In Linux I don't see the same issue.
Parents Reply Children
  • Yes, that worked. What does this mean? Why is it that for some the default version that comes with e2studio works but not for me?

  • David,

    I really don't have a good answer for you.  I have reported this the Applications team last week and I assume they are looking into the WHY.

    At least you are up and running now.

  • Hi Mike,

    I ran into this exact same issue, and your "solution" also fixed things.  Here's my sequence:

    1. I've never had e2 Studio installed on my machine before.
    2. Download and install FSP 4.6.0 for Windows (Win 10 fully patched).
    3. Run e2 Studio, create empty workspace, import customer's project as "existing project".
    4. Do a "build"... I get a one-time warning about the configured toolchain not being installed.  I'm guessing it was a specific version of ARM GCC that our customer had been using (on Linux).  Compiler yells about "bits/c++config.h" not being found for every source file.
    5. Delete project from workspace (including files), shut down e2 Studio.
    6. Download version 12.3 of arm-none-eabi as linked above and install (to C:\Arm\Arm GNU Toolchain arm-none-eabi\12.3 rel1).
    7. Restart e2 Studio.  It doesn't auto-detect the new toolchain.
    8. Go into Help / Add Renesas Toolchains, click "Scan...", nothing.  Click Add, enter the path from step 6, it finds the toolchain, click OK, Apply and Close.
    9. Re-extract customer's project into the workspace directory., and re-import the "existing project".
    10. Go into project properties as above, select the 12.3.1 toolchain.
    11. Build project, zero compiler errors.

    So yeah, there's something wrong with the "default" toolchain configuration.  Dunno what else to tell you.

    Dana M.