I am trying to work on USB device. I reviewed your sample projects. I created software using them as a reference. I also designed the hardware in accordance with your design. But the computer does not recognize the device. I tried many things for the computer. I also tried different software. But it doesn't work. What is the reason of this? I shared the sample code. Can you help? Can you show me my mistake?

Have a nice day.


Parents Reply
  • Hello ylmaz,

    After checking your sample code on RTT Viewer, I took this successful result for EK-RA6M4:

    Βut your project file uses USM Peripheral Vendor class driver and it needs two RA devices, in order to verify the correct USB operation.

    But, you just want to verify the usb connection and operation, so as JimB mentioned try to use a simple demo project to verify the usb connection.

    For example, the project below will configure the MCU as a CDC device as well as a Mass storage device.
      Tera term is used to communicate with the CDC interface of the MCU. Data written by the tera term will be echoed back on the terminal by RA board.
         User at the same time can read/write the data from/to the Mass storage device using host machine.

    The  attached project is for EK-RA6M4. If this cannot be executed correctly, your issue reason may be at hardware

    Hope it helps!



No Data