PicoFDL (T04) with IAR RL78 2.xx

Hello,

MCU: RL78/G13

We are now migrating from IAR 1.xx to 2.xx due to other issues and our dataflash library doesn´t compile with the new version because the tool provided by Renesas "RENESAS_FDL_RL78_T04E_V1.20" only allows generating libraries for 1.20 version of IAR.

Should we expect Renesas to update this tool for new versions soon? Or is it better to switch to other flash emulation library (T01 e.g.) assuming the cost in code size? Any alternative?

Thanks in advance!

Parents Reply
  • Hi.
    Perhaps you have not opened access to Data Flash
    DFLEN = 1U;
    for (w_count = 0U; w_count < 6U; w_count++)
    {
    NOP();
    }
    or not linking libraries.
    I tried the old FDL for IAR 2.x with version 4.10.1 and everything worked.
    Give me an email and I will send it to you.
    And if these files are available for you to download, it would help me.
    www2.renesas.eu/.../
    www2.renesas.eu/.../

    As for the problem I described with Type 01, I solved it. As it turned out, due to the fact that I had data previously recorded using the DFlash library, the formatting command produced an error. As soon as I erased them, everything began to work.
    my email: [email protected]
    Best Regards.
Children