RFP is not detecting the board (R5F51403ADFL) using com port

We are new to Renesas controllers. So trying to get the basic board to do sw programming using RFP.  We are using 48pin R5F51403ADFL using a breakout board so that we can test all the interfaces. Right now just setup the minimum configuration for doing the flash programming (RFP v3.0) using serial port from PC.

Got bare minimum things for the processor to be up




P30/RXD1 => Connected to TX pin of Serial to USB converter

P26/TXD1 => Connected to RX pin of the serial to USB converter

Please find the attached schematics for the board

After powering up the board we see the below message in the RFD tool

Disconnecting the tool

Error(E300010D): The device sent an unrecognized response. (0xFC)
Operation failed.

1) Just to ensure there is no race condition a the reset we tried to keep the board to reset to  (GND) while powering up and then switch to HIGH (VCC) after a delay (say 30 seconds). But still getting the same error.

2) I am assuming , first the microcontroller will come up on LOCO clock with out connecting an oscillator and still will be able to communicate with RFP. Is this correct ? 

3) any other obvious mistakes in this? 


  • Don't see anything obviously wrong with your approach, although I wonder about your reset circuit and reset timing providing clean transitions.  30s of power prior to release of reset is not necessary, the specification is only 10.5ms min between VCC ready and release, although RFP needs another 400ms before trying to communicate.  Have you looked at TXD/RXD on a scope?  

    You might consider purchasing the low-cost Target-Board for RX140 (RTK5RX1400C00000BJ).  This includes the on-board E2-Lite which allows debugging & programming over the FINE interface for this device.  This is a good reference to get started.