Using e2studio, debugger not hitting main function for RX100_R5F51105

Hello all,

I am facing challenges to perform SW debugging in e2studio. I am using KPIT GNURX-ELF Toolchain and uc is R5F51105. 

The compilation of source code works fine and I can see the updated executables in folder.

After compilation when I start to debug, initially breakpoint hits to _PowerON_Reset in reset_program.asm file.

After this I click on Resume or Restart or StartOver or StepIn option, for all these the response is same!

- Here, the breakpoint enters in free running state! And Debug window shows that No thread info available.

In debug configuration call to main function is already set - 

Still the issue remains same! - 

I assume that somewhere in a file, call to main function is missing. If so, which file or function I can refer to view this calling? Or

is there something else that is causing this issue?

Somebody please guide me to solve this issue

  • Depending on your customization of the startup code, there is likely an issue with the code getting stuck in a for-loop or perhaps there is some hardware init that is throwing an exception before main can be hit.  Step thru the code from the reset vector and see what is happening.

  • Hi @JimB,

    I tried to do step in but it doesn't go in any function or I don't see any exception. I tried looking for definition of PowerON_Reset function. But I see that it is not present in project structure! Is it possible that- due to some project settings, I cannot view that file here and that is why it is giving this issue? (e2studio version is  2.1.0.21 )

  • PowerON_Reset is the assembly label for the reset vector.

    Are you trying to run on real hardware or on a simulator?  When I build a simple test program for the R5F51105 using the last KPIT GCC tools for RX, and try to run in the simulator, it gets stuck in the clock setup routine which is expected since there is no working hardware.