Can't 'step over' or 'step return'

Hello,

I've been reading the Internet looking for this issue on Renesas forum, Stackoverflow, Eclipse forums and so on, but the only two threads that specifically adress this problem have no final fix, so I'm bringing it up again in case anyone can help me. I'm not very experienced in Eclipse, so please correct me if I write something wrong or stupid due to lack of knowledge.

My issue is that when debugging, the Step Over (F6) button works just like Step In (F5), and on the other hand Step Return (F7) works as Resume (F8). This makes it really annoying when debugging, because it's possible to do it with patiente and good breakpoints-setting skills, but it's exhausting having to either interpret all the codelines to set useful breakpoints or visit all the submethods and classes.

About my setup, I work in Renesas e² studio:

  • Version: 2024-02 (24.1.0)
  • Build ID: R20240116-1223
  • Based on Eclipse Platform 4.26 (2023-09)
  • CDT version 11.3.1
  • Enabled parallel build>Use optimal jobs (4)
  • TC_VERSION Renesas CC-RX v3.06.00
  • Renesas E1 Debugger (Don't know the exact information)

To solve the issue, I've tried in vane:

  • Entering Properties>Run/Debug Settings>Select Debugger>Edit>"Debugger" Tab>"Debug Tool Settings" subtab>in System, Enabling "Debug the program re-writing the on-chip PROGRAM ROM" and "same text... on-chip DATA FLASH" 
  • Check on Properties>C/C++ Build>Environment for Dwarf Converter Tool (non existent in my menus)
  • Disable C/C++ Build>Settings>Compiler>Optimization> Then put the Optimization level to 0 (it was already on 0 when I checked it)

If you need any more information, please tell me so.

Thanks for your time.