R8A774A2 RZG2M chip - Uboot boot failing (Chip id - R8A774A3)

Hi Support Team,

We were using hihope board for development in which we used Yocto Rocko version and kernel version 4.19, VLP package 1.0.12 based on hihope having chip ID "R8A774A1".

We received RZG2M processor physical chip from Renesas as R8A774A2 but it shows chip ID "R8A774A3" i.e. Rev3.0 in attached logs. When we boot this processor, it stucks in uboot. Please find the logs.

Query: Do we need to use dtb and other dependencies files in uboot for R8A774A1 or R8A774A3? However, in uboot source, there are no dtb and source files for R8A774A1 or R8A774A3 chip ID in VLP package 1.0.12.

Please find the logs of board bootup and the processor silicon.

NOTICE:  BL2: RZ/G2 Initial Program Loader(CA57) Rev.3.0.3
NOTICE:  BL2: PRR is RZ/G2M Ver.3.0
NOTICE:  BL2: Board is Custom Board RZ/G2M Rev.6.0
NOTICE:  BL2: Boot device is QSPI Flash(40MHz)
NOTICE:  BL2: DDR3200(rev.0.41)
NOTICE:  BL2: [COLD_BOOT]
NOTICE:  BL2: DRAM Split is 2ch
NOTICE:  BL2: QoS is default setting(rev.0.04)
NOTICE:  BL2: DRAM refresh interval 1.95 usec
NOTICE:  BL2: Periodic Write DQ Training
NOTICE:  BL2: DRAM don't have ECC configuration
NOTICE:  BL2: CH0: 400000000 - 47fffffff, 2 GiB
NOTICE:  BL2: CH2: 600000000 - 67fffffff, 2 GiB
NOTICE:  BL2: Lossy Decomp areas
NOTICE:       Entry 0: DCMPAREACRAx:0x80000540 DCMPAREACRBx:0x570
NOTICE:       Entry 1: DCMPAREACRAx:0x40000000 DCMPAREACRBx:0x0
NOTICE:       Entry 2: DCMPAREACRAx:0x20000000 DCMPAREACRBx:0x0
NOTICE:  BL2: FDT at 0xe6321a70
NOTICE:  BL2: v2.6(release):7faef7375-dirty
NOTICE:  BL2: Built : 06:36:41, Mar  1 2023
NOTICE:  BL2: Normal boot
INFO:    BL2: Doing platform setup
INFO:    BL2: Loading image id 3
NOTICE:  BL2: dst=0xe6321300 src=0x8180000 len=512(0x200)
NOTICE:  BL2: dst=0x43f00000 src=0x8180400 len=6144(0x1800)
WARNING: r-car ignoring the BL31 size from certificate,using RCAR_TRUSTED_SRAM_SIZE instead
INFO:    Loading image id=3 at address 0x44000000
NOTICE:  rcar_file_len: len: 0x0003e000
NOTICE:  BL2: dst=0x44000000 src=0x81c0000 len=253952(0x3e000)
INFO:    Image id=3 loaded: 0x44000000 - 0x4403e000
INFO:    BL2: Loading image id 5
INFO:    Loading image id=5 at address 0x50000000
NOTICE:  rcar_file_len: len: 0x00100000
NOTICE:  BL2: dst=0x50000000 src=0x8300000 len=1048576(0x100000)
INFO:    Image id=5 loaded: 0x50000000 - 0x50100000
NOTICE:  BL2: Booting BL31
INFO:    Entry point address = 0x44000000
INFO:    SPSR = 0x3cd 
U-Boot 2021.10 (Mar 01 2023 - 10:40:27 +0000) 
CPU:   Renesas Electronics R8A774A3
Model: HopeRun HiHope RZ/G2M with sub board
DRAM:  3.9 GiB
WDT:   watchdog@00000000e6020000
WDT:   Started with servicing (60s timeout)
MMC: mmc@ee100000: 0, mmc@ee160000: 1
Loading Environment from MMC... OK
In:    serial@e6e88000
Out:   serial@e6e88000
Err:   serial@e6e88000
U-boot WDT started!
Net:   
Error: ethernet@e6800000 address not set.
No ethernet found. Hit any key to stop autoboot:  2  1  0 
Card did not respond to voltage select! : -110
Couldn't find partition mmc 0:1
Can't set block device
Card did not respond to voltage select! : -110
Couldn't find partition mmc 0:1
Can't set block device
Bad Linux ARM64 Image magic!