RSK RZ/N2L Interrupt on button press not registered

Hi everyone,

I have been trying to set up an interrupt by pressing the SW1 button on the RSK RZ/N2L, but it does not work. The button is located on P16_3. I set it as IRQ7, as specified by the RSK document. I have attached a picture of the pin configuration.

When it comes to the interrupt configuration, I used the following, which seems to be fine:

And lastly, the code is simple, just enable the interrupt and wait. Once a button press occurs, trigger interrupt and toggle a value:

Still, if I put a breakpoint in debugging or just code to turn on an LED in the callback function, the function is never triggered if I press SW1. Could I be missing something fundamentally like the additional setup for the pin where the button is connected? I have tried to see if Digital filtering on the interrupt or Schmitt trigger on the pin would fix the issue but still no interrupt being triggered on button press. I have been able to create a polling approach that works, but that is not what I am looking for. Does someone have an idea what could be going on?

Best regards