RZ/G3S SCI Download mode (Due to parameter error) on start

Hello,

I'm trying to Flash RZ/G3S board using the following manual:

https://www.renesas.com/us/en/document/mas/linux-start-guide-rzg3s-board-support-package-v100

I was able to do all steps and boot up BSP linux from SD card. Then on the next day when I've turned the board on I saw the following error on screen:

SCI Download mode (Due to parameter error)                                                                                                                                                                         
-- Load Program to SRAM ---------------

This error still appears even after reflashing all images using FLashWriter tool from BSP.

After some investigations I was able to get into u-boot console after booting from eMMC.

And then I found that U-boot sees only eMMC and prints the following error when I try to access other devices:

=> mmc dev 0
switch to partitions #0, OK
mmc0(part 0) is current device
=> mmc dev 1
Card did not respond to voltage select! : -110
=> mmc dev 2
Card did not respond to voltage select! : -84
=> 

Error -84 for mmc 2 indicates that it is disabled by switches on the main board. After enabling it error message is also -110.

Also, I was able to confirm that Linux doesn't see any SD devices apart from eMMC either.

That's strange behavior because I was able to start the BSP on the board only once and then I began to get issues.

Please advise what should be done in this case.

WBR,

Oleksii.

Parents Reply Children
No Data