RZ/V2L: Camera testing commands

Hi,

We are testing camera in RZ/V2L board.

Kindly share the commands for encoding test and streaming test in camera.

Regards.

Parents
  • Hi,

    I followed the below link for testing, but some errors are thrown

    https://renesas.info/wiki/RZ-G/RZ-G2L_SMARC#Using_the_Coral_MIPI_Camera

    To capture a video i used below command:

    gst-launch-1.0 v4l2src num-buffers=3600 device=/dev/video0 ! video/x-raw,format=UYVY,width=1280,height=960,framerate=60/1 ! vspmfilter outbuf-alloc=true ! video/x-raw,format=NV12 ! omxh264enc control-rate=2 target-bitrate=10485760 interval_intraframes=14 periodicty-idr=2 no-copy=true ! video/x-h264,profile=\(string\)high,level=\(string\)4.2 ! h264parse ! video/x-h264,stream-format=avc,alignment=au ! qtmux ! queue ! filesink location=video_HD.mp4
    But i get below error:
    WARNING: erroneous pipeline: no element "vspmfilter"

    If i remove the "vspmfilter" pipeline, i get below error:
    WARNING: erroneous pipeline: syntax error

    Also, for capturing the image i used below command:
    gst-launch-1.0 v4l2src device=/dev/video0 ! videoconvert ! waylandsink
    I get below error:
    Setting pipeline to PAUSED ...
    ERROR: Pipeline doesn't want to pause.
    WARNING: from element /GstPipeline:pipeline0/GstWaylandSink:waylandsink0: Could not initialise Wayland output
    Additional debug info:
    ../git/ext/wayland/gstwaylandsink.c(473): gst_wayland_sink_find_display (): /GstPipeline:pipeline0/GstWaylandSink:waylandsink0:
    Failed to create GstWlDisplay: 'Failed to connect to the wayland display '(default)''
    Setting pipeline to NULL ...
    Total time: 0.000000 seconds
    Freeing pipeline ...

    Is there any package to add in YOCTO to test camera?
    Also, kindly share if any other commands available for testing
  • That's old stuff.

    Refer to the link Chris posted.

Reply Children
No Data