debugging 2 MCU on the same PC with e2studio

Hi everybody,

I'm developing a safety related project which is going to use 2 RX140 MCUs which need to communicate each other.

At moment, I'm using 2  "Target Board for RX140" to do preliminary tests. I would like to debug the two MCUs.

To do so, I launched two E2studio instances (each one on different workspaces) and compiled two projects.

The first project is correctly launched and debbuged, when I launch the second one I get this error

GDB Server for Renesas targets.
	Version 8.9.0.v20220622-094354 [a337bc4f] (Jul  4 2022 13:26:10)


Starting server with the following options: 
        Raw options                : C:\Users\utente\.eclipse\com.renesas.platform_1325044623\DebugComp\\RX\e2-server-gdb -g E2LITE -t R5F51403 -uConnectionTimeout= 30 -uClockSrcHoco= 1 -uPTimerClock= 48000000 -uAllowClockSourceInternal= 1 -uUseFine= 1 -uFineBaudRate= 1.50 -w 1 -z 0 -uRegisterSetting= 0 -uModePin= 0 -uChangeStartupBank= 0 -uStartupBank= 0 -uDebugMode= 0 -uExecuteProgram= 0 -uIdCode= FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF -uresetOnReload= 1 -n 0 -uWorkRamAddress= 1000 -uverifyOnWritingMemory= 0 -uProgReWriteIRom= 0 -uProgReWriteDFlash= 0 -uhookWorkRamAddr= 0x3dd0 -uhookWorkRamSize= 0x230 -uOSRestriction= 0 -l -uCore= SINGLE_CORE|enabled|1|main -uSyncMode= async -uFirstGDB= main

Connecting to E2LITE, RX Target
        GDBServer endian           : little
        Target power from emulator : On
Starting target connection
GDB action 'connect to target', has failed with error report, Failed to connect to the emulator. The specified emulator has already been used.
force_kill_gdb()
Disconnected from the Target Debugger.

In practice, it seems the second target board is not recognized even if in PC device manager it shows two "Renensas E2 lite USB development tools"

Is there any way to solve?

Thanks and regards

  • Hi,

    Think I had a similar issue some time ago. The solution was to select the serial number for each debugger in the Run/Debug Settings for each project. This is found under "Connection with Target Board" and "Emulator".

    Matt

  • Hello @Matt_Crow,

    Thank for reply. I found the configuration setting you mention but it seems one is recognized by the two IDEs.

    In fact, if I connect just one target board the serial number id is "e2l:_obe110010".

    Thus, I don't understand if the problem relies on "target boards" which have the same ID or on PC which is not able to discriminate the two target board.

    Thanks

  • Hi,

    For me both IDE's were selecting the same debugger. Therefore I had to select a different debugger by their serial number otherwise when I started to debug with the 2nd IDE it killed the first IDE's connection off. 

    In the emulator setting you should be able to deselect Auto and then select the serial number of the debugger you wish to use for that IDE.

    Matt

  • I just connected an E2 emulator lite device I have bought with the two target board and it has a differnet serial number.

    Therfore, the problem is the target boards which have the same ID.

    Does someone know how to change it?

    Thanks

  • Hello @Matt_Crow,

    I was not able to attach a screenshot but even if I deselect "auto" it is only one choice even if two target board is connected.

    As I wrote in another reply, the problem is that the two target board have the same ID. I checked attaching another e2lite emulator (the one used to program/debug) and it has a different ID.

    So I need to understand if it is possible to change the ID of one target board.

    thanks

  • Hi,

    You say you only see one ID, are both E2lite emulators seen in Device Manager?

    Each debugger/Emulator should have its own Serial ID that you can select. I'm not sure Target board ID is a factor in this problem.

    Matt

  • Hello

    Yes I see the two devices on device manager, but  the debug configuration show just one ID. That's why  I suspect the two "target board for RX140" are programmed to have the same serial number.

    Unfortunately, if I try to upload a screenshot I got an error from the website..

    Thanks

  • Hello

    I was finally able to attach a screenshot.

  • I tried to debug one MCU with E2lite and the other with E1, and only one emulator was seen by both the IDE's. I don't think that in my case both the emulators had the same ID, since they are different models. My experience was with e2studio 7.8. Maybe more recent versions solved the issue and actually support more than one emulator on the same PC. 

  • I have been using a E1 and E2lite like yourself and have different ID's for both.

    One way to check is to use the E2 Lite Self Check Program as this displays the Serial Number. Do one at a time and see if they have different ID's.

    Also worth checking does the "Debug Hardware" drop down show just one or 2 E2Lites?