IAREW RL78 Version 4.10 BLE Simple project faild to compile

Hello Experts,

We have the latest version of IAREW RL78 V4.10. Tried to compile simple BLE project but got the linker errors

Error[Lp011]: section placement failed  

 unable to complete "place at" directives with a total estimated minimum size of 0x7c bytes in <[0x4-0x53]> (total space 0x50).

Error[Lp015]: section placement failure: overcommitted content in [0x4-0x53]

Error while running Linker

I am using BLE version (BLE_Software_Ver_1_21). There are library files in the project and I think these libraries are compiled with IAREW RL78 V2.0. And it can not be compiled with the latest version of IAREW therefor linker error is generated. It is difficult to find an old version on the IAREW on the website of IAR. Can someone please update the project so that it can be compiled with the latest version of IAREW RL78. Libs included in the projects are attached in the following picture.

Looking forward to hearing from you soon. 

Best Regards,

Abdul Sattar



  • Hello,
    unfortunately I have no idea what you mean by "simple BLE project".
    The error message is not related to the library being compiled with a different compiler. The error message says it cannot place a section at the location defined in the linker script file because there is not enough space.
  • Dear Frankl,

    Thank you very much for your reply. I can not compile "project_simple" in the directory of "BLE_Software_Ver_1_21" with version V4 of IAR for RL78. I have specified the linker available in the "config" folder inside "project_simple" in IAR linker option.

    When I compile it says that linker file mismatch. Can you please compile on your side with IAREW RL78 Version 4. I have tried a lot and have been struggling for a week but not a success.

    I have attached screenshot of error please check.

    Luckily I found, with many efforts, version 2 of IAREW RL78 (30 days evaluation version). And the project compiles correctly with Version 2 without any modification. The problem with version 2 of IAREW RL78 is that it does not support E2-lite version emulator and we do not have a license too, at the moment we do not have E1 emulator that is supported in version 2 of IAREW RL78. With us right now available emulator is E2-Lite so cannot test or debug the project. I have attached the screenshot that compiles correctly with some warnings. 

    Please help us fix the problem of compilation with version 4 of IAREW RL78.

    best Regards,

    Abdul Sattar

  • @aronwarner11, thank you for posting an irrelevant reply.
    @Malokani, you don't say which project you use.
    BLE libraries are usually not available as source. So it would be better you contact your Renesas support for it.
    If you have a license for EWRL78 V4, I believe it should be possible to get a license key for EWRL78 V2 if you contact IAR.
  • the aronwarner11 reply was deleted as spam. Thank you.

    RenesasRulz Forum Moderator
  • Hello Abdul Sattar,

    I had a similar problem with the IAR compiler, even when I had a licencse.
    The problem occured with a newer Version with the IAR Compiler. I used the RL78 G1F eviroment. I found out that the x.icf file, which comes with the new compiler, was different.

    I went back in the older project and found out, that there was a small difference in the x.icf file. In my case it was the lnkr5f11bge.icf.
    I could not really explain what was the differenece, but I exchanged the x.icf file(x = your Chip type) .

    Try to use the older x.icf file for your project in the newer version. This helped me in my project.

    Good luck,
  • Malokani,

    Has your issue been resolved?

    Mike Clements
    RenesasRulz Moderator
  • Dear HJ,

    Thank you very much for you reply. I did not see any notification in my email about your message. Today, I was looking something elese and I found your suggestion. I did my best and at that time I could not solve the problem. And I changed to nordic BLE.

    Still I have RL78 ble chip with me so I will give it try as you suggested and will post here if I am able to fix the problem.

    Thank you very much,

    Abdul Sattar