DA14531 does not boot from SPI master after successful firmware transfer


I'm trying to boot the DA14531 chip from an STM32 SPI master on a custom board.
I followed the steps in AN-B-072 DA14531 Booting from serial interfaces, chapter 6.1 Boot from SPI Bus - DA1453x Act as SPI Slave:
lpccs-docs.renesas.com/.../SPI booting options.html

I am getting all the expected responses from the DA14531:
chunk 1 response=0x00 0x00 0x00 0x02
chunk 2 response=0x00 0x00 0x02 0x00
final response=0xaa 0x02

But, the firmware does not seem to boot. I have tried setting a pin to high at the end of the `periph_init` function of the DA14531 firmware:
But the level does not change when measuring the connected pin in the STM32.

I have also tried uploading a firmware binary that advertises a BLE device but the BLE device does not appear when performing a BLE scan. This firmware binary was tested and works on the official DA14531 development board.

How can I verify that the firmware booted successfully?

Kind regards,