DA16200 SDK 3.2.6 unable to build

I've installed the FreeRTOS SDK tool chain package (v1.0) and Eclipse version 2022-12 (4.26.0) on a clean/new Win10 laptop but I'm faced with a build error.:- 

10:59:06 **** Incremental Build of configuration Debug for project da16200 ****
make all
make: unknown option -- no-print-directory
BusyBox v1.36.0.git (2023-01-29 16:36:13 UTC)

Usage: make [--posix] [-C DIR] [-f FILE] [j NUM] [-eiknpqrsSt] [MACRO[::]=VAL]... [TARGET]...

Maintain files based on their dependencies

--posix Enforce POSIX mode
-C DIR Change to DIR
-f FILE Makefile
-j NUM Jobs to run in parallel (not implemented)
-e Environment variables override macros in makefiles
-i Ignore exit status
-k Continue on error
-n Dry run
-p Print macros and targets
-q Query target; exit status 1 if not up to date
-r Don't use built-in rules
-s Make silently
-S Stop on error
-t Touch files instead of making them
make: *** [makefile:121: all] Error 1
"make all" terminated with exit code 2. Build might be incomplete.

10:59:11 Build Failed. 1 errors, 0 warnings. (took 5s.101ms)

I've not found a solution on the web. Can you help?

I notice that during the install the text advised be that the install would require 3GB of HDD space! That's a lot of bloat!

I have another laptop - Win11 with Arm tools already installed but that also fails - in more interesting ways.- builds the DA16200.elf file but then fails with unable to find the file specified. I can grab logs and post here if I'm unable to get this machine building - I'm hoping to be able to find which tool it's looking for from a working buiild.



  • Hi OV_Renesas,

    Yes, I've followed those steps before I posted the problem.

    Have you tried on a clean build - without any prevoius tools installed?

    I'd love to find an old document that guided me to install the correct tools manually rather then using Xpack.



  • Hi Keith,

    Thank you for the reply.
    Unfortunately, I have not tried to build the latest SDK on a clean PC. The PC I am using has built the last 3 SDK versions without an issue.
    Are you facing this issue only on the specific setup? You are not able to build the latest SDK on any pc setup?

    Kind Regards,

  • Hi OV_Renesas,

    I only have access to the current SDK.

    I just looked at the AWS SDK but it's not a standanlone SDK I need to add the project to the existing SDK. I'm not attempting that at this stage.

    I've got access to 2 laptops.

    My home Win10 - full access - run the https://www.renesas.com/us/en/document/sws/freertos-sdk-toolchain-package-v100?r=1600096 installer, installed Eclipse, followed the instructions and it fails as described above.

    My Win11 Laptop I only have user rights so need to ask a grown up to install the tools. Given my experiance with my Win10 laptop I'm not going to bother them. I also already have the ARM tools - C:\Program Files (x86)\GNU Arm Embedded Toolchain\10 2021.10\bin and Python, Make/CMAKE etc. - remember the FreeRTOS SDK Toolchain Package v1.0.0 installer advises that the install with take an aditional 3GB! I don't wish to install duplicates of tools I already have - sounds reasonable? This build fails in different ways - not yet discussed here in detail. But I may have to run the installer just to tick the box so say it's done.

    To be clear, I don't think this is a SDK issue - it's getting the tools installed correctly. If you can share the older install/getting started docs I'm sure I can get it building. I had it wokring in a previous life ;-)



  • Hi There,

    Thank you for the replies.
    I have raised an internal ticket regarding this issue, and I will get back to both of you as soon as possible.

    Kind Regards,

Reply Children
No Data