OTAUServ Tool - ZWIR4512 Dev Kit

Hi All,

I am testing the ZWIR4512 Development Kit, in particular the OTAU functionality, but I run into the problem that it does not compile on Linux (even though the README file indicates that it does). The source code I use is the one that comes with the Kit.

My environment is as follows:

  • kernel 5.10.11-100 (Fedora 32)
  • autoconf 2.69
  • make 4.2.1
  • qt-devel 4.8.7

The procedure that I follow is the following:


$ cd [Software-Package]/src/OTAUSrv
$ autoconf
(I'm not running automake because it fails and I understand that it wouldn't be necessary since the Makefile.in file exists)
$ mkdir build
$ cd build
$ ../configure
$ make

make[1]: se entra en el directorio '/home/xxx/xxxx/Software-Package/src/OTAUSrv/build/libOTAUSrv'
g++ -c -MMD  -I. -I./.. -I../../libOTAUSrv -I../..   -fPIC  -D__MAJOR_VERSION=1 -D__MINOR_VERSION=0 -D__VERSION_EXTESION=7827 -g  -o libOTAUSrv.o ../../libOTAUSrv/libOTAUSrv.cpp
g++ -c -MMD  -I. -I./.. -I../../libOTAUSrv -I../..   -fPIC  -D__MAJOR_VERSION=1 -D__MINOR_VERSION=0 -D__VERSION_EXTESION=7827 -g  -o FirmwareFile.o ../../libOTAUSrv/FirmwareFile.cpp
g++ -c -MMD  -I. -I./.. -I../../libOTAUSrv -I../..   -fPIC  -D__MAJOR_VERSION=1 -D__MINOR_VERSION=0 -D__VERSION_EXTESION=7827 -g  -o ELFFile.o ../../libOTAUSrv/ELFFile.cpp
g++ -c -MMD  -I. -I./.. -I../../libOTAUSrv -I../..   -fPIC  -D__MAJOR_VERSION=1 -D__MINOR_VERSION=0 -D__VERSION_EXTESION=7827 -g  -o BinaryFile.o ../../libOTAUSrv/BinaryFile.cpp
g++ -c -MMD  -I. -I./.. -I../../libOTAUSrv -I../..   -fPIC  -D__MAJOR_VERSION=1 -D__MINOR_VERSION=0 -D__VERSION_EXTESION=7827 -g  -o OTAUServer.o ../../libOTAUSrv/OTAUServer.cpp
g++ -c -MMD  -I. -I./.. -I../../libOTAUSrv -I../..   -fPIC  -D__MAJOR_VERSION=1 -D__MINOR_VERSION=0 -D__VERSION_EXTESION=7827 -g  -o OTAUPacket.o ../../libOTAUSrv/OTAUPacket.cpp
g++ -c -MMD  -I. -I./.. -I../../libOTAUSrv -I../..   -fPIC  -D__MAJOR_VERSION=1 -D__MINOR_VERSION=0 -D__VERSION_EXTESION=7827 -g  -o Worker.o ../../libOTAUSrv/Worker.cpp
g++ -c -MMD  -I. -I./.. -I../../libOTAUSrv -I../..   -fPIC  -D__MAJOR_VERSION=1 -D__MINOR_VERSION=0 -D__VERSION_EXTESION=7827 -g  -o QTWorker.o ../../libOTAUSrv/QTWorker.cpp
o QTWorker_moc.cpp ../../libOTAUSrv/QTWorker.hpp
make[1]: o: No se encontró el programa
make[1]: [../MakeRules:80: QTWorker_moc.cpp] Error 127 (no tiene efecto)
g++ -c -MMD  -I. -I./.. -I../../libOTAUSrv -I../..   -fPIC  -D__MAJOR_VERSION=1 -D__MINOR_VERSION=0 -D__VERSION_EXTESION=7827 -g  -o QTWorker_moc.o QTWorker_moc.cpp
g++: error: QTWorker_moc.cpp: No existe el fichero o el directorio
g++: error fatal: no hay ficheros de entrada
compilación terminada.
make[1]: *** [../MakeRules:83: QTWorker_moc.o] Error 1
make[1]: se sale del directorio '/home/xxxx/xxxx/Software-Package/src/OTAUSrv/build/libOTAUSrv'
make: *** [../MakeTargets:153: subdir_all] Error 2

Has anyone tried this kit on Linux and been able to compile this OTA update server?

Any suggestions that this error may be?

Thanks in advance